Installation
This section describes some basic installation procedures.
Downloading the SDK and Sample Apps
Current versions of the SDK are available at http://jabberdeveloper.com. You will need to login with your Cisco credentials to access and download the SDK.
Unpacking the SDK and Sample Apps
The SDK currently comes as a zip archive. After download, extract the contents of the SDK into its own named directory. For example, on Windows systems this might be C:\SDK\jabber-guest-sdk-for-android-0.0.95\ while on OS X systems it could be /Developer/SDK/jabber-guest-sdk-for-android-0.0.50/.
Including the SDK and Sample Apps if you are using Eclipse
Pre-requisites
- Install the ADT Plugin for Eclipse
- Install the Android SDK
Eclipse
To start with the Jabber Guest SDK in Eclipse, it must first be imported as a project library. To import the SDK project and all the sample applications follow these steps:
- Select File > Import and then, from the import source dialog, select Android > Existing Android Code into Workspace.
- Click Next.
- On the Import Projects dialog page, make sure the Select root directory checkbox is checked and click Browse to locate where you have unpacked the SDK.

- Browse to the root directory of the unpacked SDK and click OK. If everything is correct, you should see six projects in the Projects section of the Import Projects dialog page.
- To install all SDK elements, check all the projects or click Select All. If any are greyed out and cannot be checked, it means you have already imported that project or there is a conflict with the project name.
- When all projects are checked for import, click Finish to import.

Including the SDK and Sample Apps if you are using Android Studio.
Pre-requisites
- Install the Android SDK
Android Studio
To start with the Jabber Guest SDK in Android Studio it must first be imported as a project library. To import the SDK project and all the sample applications, following these steps:
- From the Quick Start menu, select Import Non-Android Studio project.
- On the Select Eclipse or Gradle Project to Import dialog page, browse to where you unpacked the SDK and select the root directory.

- Click OK.
- On the Import Project dialog box, select Create project from existing sources and click Next.
- Click Next.
- To import all SDK elements, check all the projects and source files in the Import Project dialog. Then click Next.
- Review the libraries and check the checkboxes for libs and android-support-v4. Then click Next.

- Leave the module structure for the project as is and click Next.

- Select the project SDK (API 15 or higher) and click Next.

- Check the checkboxes for each of the Android Manifest.xml files for each sample app and sdk.
- Click Finish.
- To run the existing sample apps, go to File > Project Structure and under Project Settings, select Modules.
- Select the Dependencies tab and add the android library by clicking the + and clicking Library. Select the android-support-v4 library and click Add Selected. Do this step for each of the sample apps you want to compile and run.
- The sample apps should now be able to compile and run on your device.
Including the SDK Within Your Own Apps if you are using Eclipse
If you have any existing Android projects open in Eclipse and would like to include the SDK in those projects, follow these steps:
- Select your open project in Eclipse and either select Project > Properties from the main menu or alternate-click on the Project itself and select Properties from the context menu. If your project nature is correctly set to Android, your project dialog will contain Android and Android Lint Preferences sections.

- Within the Android section, click Add from the bottom Library panel and then select “sdk” from the offered library projects. If “sdk” is not shown, ensure the Jabber SDK project is imported and open.

- Click OK and the Jabber Guest for Android SDK library should now be referenced by your project.
Including the SDK within Your Own Apps using Android Studio
If you have any existing Android Studio projects open and would like to include the SDK in those projects, follow these steps:
- Select your open projects in Android Studio and go to File > Project Structure.
- Under Project Settings, select Modules.
- Select the Dependencies tab
- Click the + and select Module Dependency
- Select the sdk and click OK.
- If sdk is not shown, ensure the Jabber Guest SDK project is imported and open.
- Click OK and the Jabber Guest for Android SDK library should now be referenced by your project.