|
IP*Works! V8 | ||||||||
| PREV CLASS NEXT CLASS | FRAMES NO FRAMES | ||||||||
| SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD | ||||||||
java.lang.Object | +--ipworks.Nntp
The NNTP bean is used to read and post articles on Usenet news servers.
The NNTP bean implements a standard Usenet news reader as specified in RFC 977. It can be used to browse Usenet news groups and read and post articles.
The CurrentGroup property sets the current newsgroup. From then on, news articles from that
group can be read by setting the article number in CurrentArticle and
then calling the appropriate method. Properties such as ArticleCount , FirstArticle , LastArticle provide information about
the current state.
The headers and text of the articles are received respectively through the Header and Transfer events. Additionally, up to MaxLines from the article body are provided
in the ArticleText property. The GroupOverview event returns
information about a range of articles ( OverviewRange ) in CurrentGroup ,
and the GroupList event is used when listing newsgroup names. The PITrail event provides a trace of the interaction with the server.
The bean supports posting of articles through the ArticleText and AttachedFile properties. The article text is specified in one or both
of the above, and then the PostArticle method is called.
Article headers are given in a series of properties
like ArticleFrom , ArticleSubject , Organization , etc. that map directly to the
USENET article header with the same name.
| Constructor Summary | |
Nntp()
|
|
| Method Summary | |
void |
addNntpEventListener(ipworks.NntpEventListener l)
|
java.lang.String |
config(java.lang.String configurationString)
Sets or retrieves a beanconfiguration setting. |
void |
connect()
Connect to the news server. |
void |
disconnect()
Disconnect from the news server. |
void |
doEvents()
Processes events from the internal message queue. |
void |
fetchArticle()
Get the headers and body of an article specified in CurrentArticle . |
void |
fetchArticleBody()
Get only the body of an article specified in CurrentArticle . |
void |
fetchArticleHeaders()
Get only the headers of an article specified in CurrentArticle . |
int |
getArticleCount()
The estimated number of articles in CurrentGroup . |
java.lang.String |
getArticleDate()
The date of the current article. |
java.lang.String |
getArticleFrom()
The email address of the author (for posting articles). |
java.lang.String |
getArticleHeaders()
The full headers of the article as retrieved from the server. |
java.lang.String |
getArticleId()
The message-id of the current article. |
ArticleInfoList |
getArticleList()
Collection of articles collected through GroupOverview or GroupSearch . |
java.lang.String |
getArticleReferences()
Articles the posted article follows up to. |
java.lang.String |
getArticleReplyTo()
The address to reply to (for posting articles). |
java.lang.String |
getArticleSubject()
The article subject (for posted articles). |
java.lang.String |
getArticleText()
The full text of the article (without the headers). |
java.lang.String |
getAttachedFile()
A file name of which the contents will be appended to ArticleText when posting articles. |
java.lang.String |
getCheckDate()
The date (format YYMMDD HHMMSS) to check for creation of new groups. |
java.lang.String |
getCurrentArticle()
The number or message-id of the current article. |
java.lang.String |
getCurrentGroup()
The name of the current group. |
ipworks.Firewall |
getFirewall()
A set of properties related to firewall access. |
int |
getFirstArticle()
The number of the first article in CurrentGroup. |
GroupInfoList |
getGroupList()
Collection of newsgroups listed by ListGroups or ListNewGroups . |
int |
getLastArticle()
The number of the last article in CurrentGroup . |
java.lang.String |
getLastReply()
The last reply from the server. |
java.lang.String |
getLocalFile()
The path to a local file for downloading the article body. |
java.lang.String |
getLocalHost()
The name of the local host or user-assigned IP interface through which connections are initiated or accepted. |
int |
getMaxLines()
The maximum number of message lines besides headers to retrieve. |
java.lang.String |
getNewsgroups()
A comma separated list of newsgroups in which to post the article. |
int |
getNewsPort()
The server port for NNTP (default 119). |
java.lang.String |
getNewsServer()
The name or address of a news server. |
java.lang.String |
getOrganization()
The organization of the author (for posting articles). |
java.lang.String |
getOtherHeaders()
An RFC850 compliant string consisting of extra headers (for posting articles). |
java.lang.String |
getOverviewRange()
A range for the GroupOverview method (first-last). |
HeaderList |
getParsedHeaders()
A cllection of headers returned from the last article retrieval. |
java.lang.String |
getPassword()
A login password to login with in the NewsServer . |
java.lang.String |
getSearchHeader()
A header for the GroupSearch method. |
java.lang.String |
getSearchPattern()
A search pattern for the GroupSearch method. |
java.lang.String |
getSearchRange()
A range for the GroupSearch method (first-last). |
int |
getTimeout()
A timeout for the bean. |
java.lang.String |
getUser()
A user id to login as in the NewsServer . |
void |
groupOverview()
Receive an overview for the articles in range OverviewRange in the CurrentGroup . |
void |
groupSearch()
Receive an overview for the articles in range SearchRange in the CurrentGroup . |
void |
interrupt()
Interrupt the current method. |
boolean |
isConnected()
Shows whether the bean is connected. |
boolean |
isIdle()
The current status of the component. |
void |
listGroups()
List all groups on the server. |
void |
listNewGroups()
List all new groups on the server. |
java.lang.String |
localizeDate(java.lang.String dateTime)
Converts a valid RFC 822 message date to local date and time. |
void |
postArticle()
Post the current article and attached file. |
void |
removeNntpEventListener(ipworks.NntpEventListener l)
|
void |
resetHeaders()
Reset all of the article headers. |
void |
setArticleFrom(java.lang.String articleFrom)
The email address of the author (for posting articles). |
void |
setArticleReferences(java.lang.String articleReferences)
Articles the posted article follows up to. |
void |
setArticleReplyTo(java.lang.String articleReplyTo)
The address to reply to (for posting articles). |
void |
setArticleStream(java.io.OutputStream articleStream)
Post the current article and attached file. |
void |
setArticleSubject(java.lang.String articleSubject)
The article subject (for posted articles). |
void |
setArticleText(java.lang.String articleText)
The full text of the article (without the headers). |
void |
setAttachedFile(java.lang.String attachedFile)
A file name of which the contents will be appended to ArticleText when posting articles. |
void |
setCheckDate(java.lang.String checkDate)
The date (format YYMMDD HHMMSS) to check for creation of new groups. |
void |
setCommand(java.lang.String command)
Can be used to send additional commands directly to the server. |
void |
setConnected(boolean connected)
Shows whether the bean is connected. |
void |
setCurrentArticle(java.lang.String currentArticle)
The number or message-id of the current article. |
void |
setCurrentGroup(java.lang.String currentGroup)
The name of the current group. |
void |
setFirewall(ipworks.Firewall firewall)
A set of properties related to firewall access. |
void |
setLocalFile(java.lang.String localFile)
The path to a local file for downloading the article body. |
void |
setLocalHost(java.lang.String localHost)
The name of the local host or user-assigned IP interface through which connections are initiated or accepted. |
void |
setMaxLines(int maxLines)
The maximum number of message lines besides headers to retrieve. |
void |
setNewsgroups(java.lang.String newsgroups)
A comma separated list of newsgroups in which to post the article. |
void |
setNewsPort(int newsPort)
The server port for NNTP (default 119). |
void |
setNewsServer(java.lang.String newsServer)
The name or address of a news server. |
void |
setOrganization(java.lang.String organization)
The organization of the author (for posting articles). |
void |
setOtherHeaders(java.lang.String otherHeaders)
An RFC850 compliant string consisting of extra headers (for posting articles). |
void |
setOverviewRange(java.lang.String overviewRange)
A range for the GroupOverview method (first-last). |
void |
setPassword(java.lang.String password)
A login password to login with in the NewsServer . |
void |
setSearchHeader(java.lang.String searchHeader)
A header for the GroupSearch method. |
void |
setSearchPattern(java.lang.String searchPattern)
A search pattern for the GroupSearch method. |
void |
setSearchRange(java.lang.String searchRange)
A range for the GroupSearch method (first-last). |
void |
setTimeout(int timeout)
A timeout for the bean. |
void |
setUser(java.lang.String user)
A user id to login as in the NewsServer . |
| Methods inherited from class java.lang.Object |
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait |
| Constructor Detail |
public Nntp()
| Method Detail |
public int getArticleCount()
CurrentGroup .
The value of this property is 0 if there is no current
group ( CurrentGroup is ""). Otherwise, it is the
number of articles in the group as shown by the news
server when CurrentGroup is set. For most
news servers, this is an estimated value of the
number of the articles, rather than the exact value.
public java.lang.String getArticleDate()
If the bean is not connected or CurrentArticle is empty, the value of this property is an
empty string. Otherwise, it contains the date of the article as reported by the server.
The NewsServer is asked about the headers of the article only if the CurrentArticle property has
changed. If CurrentArticle has not changed, the bean returns a cached value.
public java.lang.String getArticleFrom()
The string in ArticleFrom is posted with a From article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleFrom(java.lang.String articleFrom)
throws IPWorksException
The string in ArticleFrom is posted with a From article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksExceptionpublic java.lang.String getArticleHeaders()
If the bean is not connected or CurrentArticle is empty,
the value of this property is an
empty string. Otherwise, it contains the full headers of the article
as reported by the server.
The NewsServer is asked about the headers of the article only
if the CurrentArticle property has changed. If CurrentArticle has not changed, the bean returns a cached value.
public java.lang.String getArticleId()
If the bean is not connected or CurrentArticle is empty, the value of this property is an
empty string. Otherwise, it contains the message-id of the article as reported by the server.
The NewsServer is asked about the headers of the article only if the CurrentArticle property has
changed. If CurrentArticle has not changed, the bean returns a cached value.
public ArticleInfoList getArticleList()
GroupOverview or GroupSearch .
This collection consists of a list of ARTICLEINFO objects. The returned list contains information
about each article in the OverviewRange or SearchRange when
either GroupOverview or GroupSearch is
called.
MaxArticleInfoscan be used to control the number of articles saved.
This collection is indexed from 0 to Count - 1.
public java.lang.String getArticleReferences()
If the ArticleReferences property contains a non-empty string,
a References article header is created for the article.
This header shows the article-ids the posted article refers
to.
The references must be separated by space scharacters.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleReferences(java.lang.String articleReferences)
throws IPWorksException
If the ArticleReferences property contains a non-empty string,
a References article header is created for the article.
This header shows the article-ids the posted article refers
to.
The references must be separated by space scharacters.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksExceptionpublic java.lang.String getArticleReplyTo()
If the ArticleReplyTo property contains a non-empty string,
a Reply-To article header is created for the article.
This header shows the address to use for replies (useful
if this address is different from the one in ArticleFrom ).
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleReplyTo(java.lang.String articleReplyTo)
throws IPWorksException
If the ArticleReplyTo property contains a non-empty string,
a Reply-To article header is created for the article.
This header shows the address to use for replies (useful
if this address is different from the one in ArticleFrom ).
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksExceptionpublic java.lang.String getArticleSubject()
The string in ArticleSubject is posted with a Subject article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleSubject(java.lang.String articleSubject)
throws IPWorksException
The string in ArticleSubject is posted with a Subject article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksExceptionpublic java.lang.String getArticleText()
If the bean is not connected or CurrentArticle is empty,
the value of this property is an
empty string. Otherwise, it contains the full text of the article
as reported by the server.
The NewsServer is asked about the text of the article only
if the CurrentArticle property has changed. If CurrentArticle has not changed, the bean returns a cached value.
When posting articles, the ArticleText property contains the full text of
the article to post.
It is advisable that the text contained in this property be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the article lines must contain 7-bit characters so that the article can be successfully transferred through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another "." as specified in RFC 977. The article text is unescaped by the news server, so the process is fully transparent.
public void setArticleText(java.lang.String articleText)
throws IPWorksException
If the bean is not connected or CurrentArticle is empty,
the value of this property is an
empty string. Otherwise, it contains the full text of the article
as reported by the server.
The NewsServer is asked about the text of the article only
if the CurrentArticle property has changed. If CurrentArticle has not changed, the bean returns a cached value.
When posting articles, the ArticleText property contains the full text of
the article to post.
It is advisable that the text contained in this property be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the article lines must contain 7-bit characters so that the article can be successfully transferred through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another "." as specified in RFC 977. The article text is unescaped by the news server, so the process is fully transparent.
IPWorksExceptionpublic java.lang.String getAttachedFile()
The content of AttachedFile is appended to the text
in ArticleText (if any) and sent to the news server.
This property is useful for posting arbitrarily large
articles and/or sending MIME attachments.
It is advisable that the text contained in the file be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the message lines must contain only 7-bit characters so that the message may be successfully sent through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another as specified in RFC 822. The article text is unescaped by the news server, so the process is fully transparent.
public void setAttachedFile(java.lang.String attachedFile)
throws IPWorksException
The content of AttachedFile is appended to the text
in ArticleText (if any) and sent to the news server.
This property is useful for posting arbitrarily large
articles and/or sending MIME attachments.
It is advisable that the text contained in the file be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the message lines must contain only 7-bit characters so that the message may be successfully sent through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another as specified in RFC 822. The article text is unescaped by the news server, so the process is fully transparent.
IPWorksExceptionpublic java.lang.String getCheckDate()
The value of this property is used as an argument for
the ListNewGroups method.
public void setCheckDate(java.lang.String checkDate)
throws IPWorksException
The value of this property is used as an argument for
the ListNewGroups method.
IPWorksException
public void setCommand(java.lang.String command)
throws IPWorksException
Check the LastReply property and/or trap the PITrail events
comming from the server to get the response.
IPWorksExceptionpublic boolean isConnected()
Use this property to determine whether the bean is connected to the remote host or not.
public void setConnected(boolean connected)
throws IPWorksException
Use this property to determine whether the bean is connected to the remote host or not.
IPWorksExceptionpublic java.lang.String getCurrentArticle()
The CurrentArticle property specifies either
a message id or an article number uniquely identifying
a particular article. It is then used as an argument
to methods such as FetchArticle .
public void setCurrentArticle(java.lang.String currentArticle)
throws IPWorksException
The CurrentArticle property specifies either
a message id or an article number uniquely identifying
a particular article. It is then used as an argument
to methods such as FetchArticle .
IPWorksExceptionpublic java.lang.String getCurrentGroup()
When the CurrentGroup property is set to a valid
group name, the bean sends an NNTP GROUP command to the NewsServer and enters the specified
group. If the command is successful, FirstArticle , LastArticle , and ArticleCount are set to the
reported values for the group. CurrentGroup is then
used for all references to articles (until changed to
another group).
public void setCurrentGroup(java.lang.String currentGroup)
throws IPWorksException
When the CurrentGroup property is set to a valid
group name, the bean sends an NNTP GROUP command to the NewsServer and enters the specified
group. If the command is successful, FirstArticle , LastArticle , and ArticleCount are set to the
reported values for the group. CurrentGroup is then
used for all references to articles (until changed to
another group).
IPWorksExceptionpublic ipworks.Firewall getFirewall()
This is a FIREWALL type property which
contains fields describing the firewall
through which the bean will attempt to connect.
public void setFirewall(ipworks.Firewall firewall)
throws IPWorksException
This is a FIREWALL type property which
contains fields describing the firewall
through which the bean will attempt to connect.
IPWorksExceptionpublic int getFirstArticle()
The value of this property is 0 if there is no current
group ( CurrentGroup is "").
public GroupInfoList getGroupList()
ListGroups or ListNewGroups .
This collection consists of a list of GROUPINFO objects. These objects contain information
about each group such as the name, first and last
article, and whether or not you can post to the group.
MaxGroupInfoscan be used to control the number of groups saved.
This collection is indexed from 0 to Count - 1.
public boolean isIdle()
Idle will be False if the component is currently busy (communicating
and/or waiting for an answer), and True at all other times.
public int getLastArticle()
CurrentGroup .
The value of this property is 0 if there is no current
group ( CurrentGroup is "").
public java.lang.String getLastReply()
This is the last reply received from the server. It
can be used for information purposes. The same information
and more can also be retrieved through the PITrail event.
public java.lang.String getLocalFile()
The LocalFile property is used when retrieving an article.
If LocalFile is empty then the received data is provided through
the parameters of the Transfer event
public void setLocalFile(java.lang.String localFile)
throws IPWorksException
The LocalFile property is used when retrieving an article.
If LocalFile is empty then the received data is provided through
the parameters of the Transfer event
IPWorksExceptionpublic java.lang.String getLocalHost()
The LocalHost property contains the name of the local host
as obtained by the gethostname() system call, or if the
user has assigned an IP address, the value of that address.
In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the bean initiate connections (or accept in the case of server beans) only through that interface.
If the bean is connected, the LocalHost property shows
the IP address of the interface through which the connection
is made in internet dotted format (aaa.bbb.ccc.ddd). In most
cases, this is the address of the local host, except for multihomed
hosts (machines with more than one IP interface).
NOTE: LocalHost is not persistent. You must always set it in
code, and never in the property window.
public void setLocalHost(java.lang.String localHost)
throws IPWorksException
The LocalHost property contains the name of the local host
as obtained by the gethostname() system call, or if the
user has assigned an IP address, the value of that address.
In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the bean initiate connections (or accept in the case of server beans) only through that interface.
If the bean is connected, the LocalHost property shows
the IP address of the interface through which the connection
is made in internet dotted format (aaa.bbb.ccc.ddd). In most
cases, this is the address of the local host, except for multihomed
hosts (machines with more than one IP interface).
NOTE: LocalHost is not persistent. You must always set it in
code, and never in the property window.
IPWorksExceptionpublic int getMaxLines()
The MaxLines property is used to limit the number
of text lines besides headers retrieved for messages.
This property is used in conjunction with the ArticleText property. Please note that due to NNTP protocol limitations,
the full text of the article
is always retrieved from the server, but only MaxLines will be stored in ArticleText .
The default value of the property is 0. In this case the entire message will be retrieved, without interruptions.
public void setMaxLines(int maxLines)
throws IPWorksException
The MaxLines property is used to limit the number
of text lines besides headers retrieved for messages.
This property is used in conjunction with the ArticleText property. Please note that due to NNTP protocol limitations,
the full text of the article
is always retrieved from the server, but only MaxLines will be stored in ArticleText .
The default value of the property is 0. In this case the entire message will be retrieved, without interruptions.
IPWorksExceptionpublic java.lang.String getNewsgroups()
The string in Newsgroups is posted with a Newsgroups article header to the news server. It specifies the list
of groups where the article is posted (comma separated).
If the Newsgroups property contains "" (empty string), then
the value of the CurrentGroup property is used to specify
the target newsgroup for the posted article.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setNewsgroups(java.lang.String newsgroups)
throws IPWorksException
The string in Newsgroups is posted with a Newsgroups article header to the news server. It specifies the list
of groups where the article is posted (comma separated).
If the Newsgroups property contains "" (empty string), then
the value of the CurrentGroup property is used to specify
the target newsgroup for the posted article.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksExceptionpublic int getNewsPort()
A valid port number (a value between 1 and 65535) is required for the connection to take place. The property must be set before a connection is attempted and cannot be changed once a connection is established. Any attempt to change this property while connected will fail with an error.
public void setNewsPort(int newsPort)
throws IPWorksException
A valid port number (a value between 1 and 65535) is required for the connection to take place. The property must be set before a connection is attempted and cannot be changed once a connection is established. Any attempt to change this property while connected will fail with an error.
IPWorksExceptionpublic java.lang.String getNewsServer()
The NewsServer property specifies the IP address (IP number in
dotted internet format) or Domain Name for the news server. It is
set before a connection is attempted and cannot be changed once
a connection is in progress.
If the NewsServer property is set to a Domain Name, a DNS request
is initiated and upon successful termination of the request, the NewsServer property is set to the corresponding address. If the
search is not successful, an error is returned.
If the bean is configured to use a SOCKS firewall, the value assigned to this property may be preceeded with a "*". If this is the case, the host name is passed to the firewall unresolved and the firewall performs the DNS resolution.
public void setNewsServer(java.lang.String newsServer)
throws IPWorksException
The NewsServer property specifies the IP address (IP number in
dotted internet format) or Domain Name for the news server. It is
set before a connection is attempted and cannot be changed once
a connection is in progress.
If the NewsServer property is set to a Domain Name, a DNS request
is initiated and upon successful termination of the request, the NewsServer property is set to the corresponding address. If the
search is not successful, an error is returned.
If the bean is configured to use a SOCKS firewall, the value assigned to this property may be preceeded with a "*". If this is the case, the host name is passed to the firewall unresolved and the firewall performs the DNS resolution.
IPWorksExceptionpublic java.lang.String getOrganization()
If the Organization property contains a non-empty string,
an Organization article header is created for the article.
This header shows the organization of the author and is used
for information purposes only.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setOrganization(java.lang.String organization)
throws IPWorksException
If the Organization property contains a non-empty string,
an Organization article header is created for the article.
This header shows the organization of the author and is used
for information purposes only.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksExceptionpublic java.lang.String getOtherHeaders()
The OtherHeaders property contains a string of headers
to be appended to the message headers created from other
properties like From , Subject , etc.
The headers must be of the format "header: value" as specified in RFC 850. [Header lines should be separated by CRLF ("\\r\\n") .
Use this property with caution. If OtherHeaders contains
invalid headers, article posting might not be successful.
The OtherHeaders property is useful for extending the
functionality of the bean. A good example is posting of
MIME attachments.
SPECIAL CASE: if OtherHeaders starts with an empty line (CRLF),
then the value of OtherHeaders is used instead of the normally
computed article headers.
public void setOtherHeaders(java.lang.String otherHeaders)
throws IPWorksException
The OtherHeaders property contains a string of headers
to be appended to the message headers created from other
properties like From , Subject , etc.
The headers must be of the format "header: value" as specified in RFC 850. [Header lines should be separated by CRLF ("\\r\\n") .
Use this property with caution. If OtherHeaders contains
invalid headers, article posting might not be successful.
The OtherHeaders property is useful for extending the
functionality of the bean. A good example is posting of
MIME attachments.
SPECIAL CASE: if OtherHeaders starts with an empty line (CRLF),
then the value of OtherHeaders is used instead of the normally
computed article headers.
IPWorksExceptionpublic java.lang.String getOverviewRange()
GroupOverview method (first-last).
The OverviewRange specifies a range of articles
for which to retrieve article overviews from the server. The format
is 'first-last' where first is "" (empty string) or
a positive number, and last is "" (empty string), a positive
number, or the token end .
The default value of the property is '-', meaning 'all articles in the group' .
public void setOverviewRange(java.lang.String overviewRange)
throws IPWorksException
GroupOverview method (first-last).
The OverviewRange specifies a range of articles
for which to retrieve article overviews from the server. The format
is 'first-last' where first is "" (empty string) or
a positive number, and last is "" (empty string), a positive
number, or the token end .
The default value of the property is '-', meaning 'all articles in the group' .
IPWorksExceptionpublic HeaderList getParsedHeaders()
This property is populated when either FetchArticle or FetchArticleHeaders is called, and contains a list of all of the headers from
the article fetched.
If the header line being retrieved is a continuation header line, then the Field parameter contains "" (empty string).
MaxHeaderscan be used to control the number of headers saved.
This collection is indexed from 0 to Count - 1.
public java.lang.String getPassword()
NewsServer .
If the Password property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO PASS
command is sent in order to provide authentication
information for the user. This command is not part
of the NNTP protocol, but it is widely used by popular
news servers.
public void setPassword(java.lang.String password)
throws IPWorksException
NewsServer .
If the Password property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO PASS
command is sent in order to provide authentication
information for the user. This command is not part
of the NNTP protocol, but it is widely used by popular
news servers.
IPWorksExceptionpublic java.lang.String getSearchHeader()
GroupSearch method.
The SearchHeader property specifies the header to search
for SearchPattern (e.g. "Subject").
public void setSearchHeader(java.lang.String searchHeader)
throws IPWorksException
GroupSearch method.
The SearchHeader property specifies the header to search
for SearchPattern (e.g. "Subject").
IPWorksExceptionpublic java.lang.String getSearchPattern()
GroupSearch method.
The format of the pattern is the same as the patterns used by the UNIX 'find' command.
As an example, "* new *" will match all headers that contain the word "new".
public void setSearchPattern(java.lang.String searchPattern)
throws IPWorksException
GroupSearch method.
The format of the pattern is the same as the patterns used by the UNIX 'find' command.
As an example, "* new *" will match all headers that contain the word "new".
IPWorksExceptionpublic java.lang.String getSearchRange()
GroupSearch method (first-last).
The SearchRange specifies a range of articles for which to to do a search on the server. The format is 'first-last' where first is "" (empty string) or a positive number, and last is "" (empty string), a positive number, or the token end .
The default value of the property is '-', meaning 'search all articles in the group' .
public void setSearchRange(java.lang.String searchRange)
throws IPWorksException
GroupSearch method (first-last).
The SearchRange specifies a range of articles for which to to do a search on the server. The format is 'first-last' where first is "" (empty string) or a positive number, and last is "" (empty string), a positive number, or the token end .
The default value of the property is '-', meaning 'search all articles in the group' .
IPWorksExceptionpublic int getTimeout()
If the Timeout property is set to 0, all operations
will run uninterrupted until successful completion, or an error condition
is encountered.
If Timeout is set to a positive value, the bean will
wait for the operation to complete before returning control.
The bean will use DoEvents to enter an efficient wait loop
during any potential waiting period, making sure that all system events
are processed immediately as they arrive. This ensures that the host
application does not "freeze" and remains responsive.
If Timeout expires, and the operation is not yet complete,
the bean throws an IPWorksException
raises an IPWorksException exception
.
Please note that by default, all timeouts are inactivity timeouts ,
i.e. the timeout period is extended by Timeout seconds when
data is successfully sent or received.
Optionally, the behaviour of the bean may be changed to absolute timeouts , i.e. the bean will wait for a maximum
of Timeout seconds since the beginning of the operation, without
extending the timeout period during communications.
This behavior is controlled by theAbsoluteTimeoutconfiguration setting.
The default value for the Timeout property is 60 (seconds).
public void setTimeout(int timeout)
throws IPWorksException
If the Timeout property is set to 0, all operations
will run uninterrupted until successful completion, or an error condition
is encountered.
If Timeout is set to a positive value, the bean will
wait for the operation to complete before returning control.
The bean will use DoEvents to enter an efficient wait loop
during any potential waiting period, making sure that all system events
are processed immediately as they arrive. This ensures that the host
application does not "freeze" and remains responsive.
If Timeout expires, and the operation is not yet complete,
the bean throws an IPWorksException
raises an IPWorksException exception
.
Please note that by default, all timeouts are inactivity timeouts ,
i.e. the timeout period is extended by Timeout seconds when
data is successfully sent or received.
Optionally, the behaviour of the bean may be changed to absolute timeouts , i.e. the bean will wait for a maximum
of Timeout seconds since the beginning of the operation, without
extending the timeout period during communications.
This behavior is controlled by theAbsoluteTimeoutconfiguration setting.
The default value for the Timeout property is 60 (seconds).
IPWorksExceptionpublic java.lang.String getUser()
NewsServer .
If the User property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO USER
command is sent in order to provide authentication
information for the user. Although this command is not part
of the NNTP protocol, it is widely used by news servers for
authentication purposes.
public void setUser(java.lang.String user)
throws IPWorksException
NewsServer .
If the User property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO USER
command is sent in order to provide authentication
information for the user. Although this command is not part
of the NNTP protocol, it is widely used by news servers for
authentication purposes.
IPWorksException
public java.lang.String config(java.lang.String configurationString)
throws IPWorksException
Config is a generic method available in every bean.
It is used to set and retrieveconfiguration settingsfor the
bean.
Configuration settings are similar in functionality to properties,
but they are rarely used. In order to avoid "polluting" the property
namespace of the bean, access to these internal properties is provided through the Config method.
To set a configuration setting named PROPERTY , you must call Config("PROPERTY=VALUE") , where VALUE is the value of the setting expressed as a string. For boolean values, use the strings "True", "False", "0", "1", "Yes", or "No" (case does not matter).
To read (query) the value of a configuration setting, you must call Config("PROPERTY") . The value will be returned as a string.
IPWorksException
public void connect()
throws IPWorksException
Connect to the news server. If the User and/or Password are set,
then corresponding AUTHINFO commands are sent to the NewsServer as well.
IPWorksException
public void disconnect()
throws IPWorksException
Disconnect from the NewsServer . First the bean attempts to send
a QUIT command, and if that fails, the connection is broken.
IPWorksException
public void doEvents()
throws IPWorksException
When DoEvents is called, the bean processes any
available events. If no events are available, it waits for a
preset period of time, and then returns.
IPWorksException
public void fetchArticle()
throws IPWorksException
CurrentArticle .
Get the headers and body of the article specified in CurrentArticle .
The headers are delivered via the Header event, and the article body
via the Transfer event.
If a connection to the NewsServer doesn't
already exist, a new one is created.
IPWorksException
public void fetchArticleBody()
throws IPWorksException
CurrentArticle .
Get only the body of the article specified in CurrentArticle .
The body via the Transfer event.
If a connection to the NewsServer doesn't already exist, a new one is created.
IPWorksException
public void fetchArticleHeaders()
throws IPWorksException
CurrentArticle .
Get only the headers of the article specified in CurrentArticle .
The headers are delivered via the Header event.
If a connection to the NewsServer doesn't already exist, a new
one is created.
IPWorksException
public void groupOverview()
throws IPWorksException
OverviewRange in the CurrentGroup .
Receive an overview for the articles in range OverviewRange in the CurrentGroup . The overview data is delivered via the GroupOverview event.
If a connection to the NewsServer doesn't already exist, a new
one is created.
IPWorksException
public void groupSearch()
throws IPWorksException
SearchRange in the CurrentGroup .
Searches the current newsgroup for articles in range SearchRange in the CurrentGroup , where SearchHeader matches SearchPattern . The results
are delivered via the GroupSearch event.
If a connection to the NewsServer doesn't already exist, a new
one is created.
IPWorksException
public void interrupt()
throws IPWorksException
If there is no method in progress, Interrupt simply returns doing nothing.
IPWorksException
public void listGroups()
throws IPWorksException
Asks the server to list all its newsgroups. Use this method with
caution as listing groups may take quite a long over slow links. The group names and
other information are returned via the GroupList event.
If a connection to the NewsServer doesn't already exist, a new one
is created.
IPWorksException
public void listNewGroups()
throws IPWorksException
Asks the server to list all the newsgroups created since CheckDate .
The group names (if any) and other information are returned via the GroupList event.
If a connection to the NewsServer doesn't already exist,
a new one is created.
IPWorksException
public java.lang.String localizeDate(java.lang.String dateTime)
throws IPWorksException
This method can be used to convert an RFC 822 date/time string to the corresponding local date and time.
Dates will be returned in the format: "MM/dd/yyyy hh:mm:ss".
IPWorksException
public void postArticle()
throws IPWorksException
Post the current article and attached file (if any). If a connection to the NewsServer doesn't already exist, a new one is created.
IPWorksException
public void resetHeaders()
throws IPWorksException
Resets all the article headers to "" (empty string). Use this property before posting a new article, so that headers from the previous article are not carried over to the next one.
IPWorksException
public void setArticleStream(java.io.OutputStream articleStream)
throws IPWorksException
Post the current article and attached file (if any). If a connection
exists, and the ConnectionId is specified, that connection is
used. However, if a connection to the NewsServer doesn't already
exist, a new one is created.
IPWorksException
public void addNntpEventListener(ipworks.NntpEventListener l)
throws java.util.TooManyListenersException
java.util.TooManyListenersExceptionpublic void removeNntpEventListener(ipworks.NntpEventListener l)
|
IP*Works! V8 | ||||||||
| PREV CLASS NEXT CLASS | FRAMES NO FRAMES | ||||||||
| SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD | ||||||||