|
IP*Works! SSL V6 | ||||||||
| PREV CLASS NEXT CLASS | FRAMES NO FRAMES | ||||||||
| SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD | ||||||||
java.lang.Object | +--ipworksssl.Nntps
The NNTPS bean is used to read and post articles on Usenet news servers.
The NNTPS bean is the SSL-enabled equivalent of the
IP*Works! NNTP bean. The main difference is the introduction of a set of
new configuration settings, properties and events that deal
with SSL security. TheSSLProviderconfiguration setting chooses a security
provider subsystem. TheSSLEnabledProtocolsandSSLCipherStrengthconfiguration settings determine which protocols are enabled and at what security level.
The SSLCertStore , SSLCertSubject , and SSLCertEncoded properties are
used to select a
client certificate if the server is requesting client authentication.
TheSSLSecurityFlagsconfiguration setting, together with the SSLServerAuthentication event
allow you to check the server identity and other security attributes.
Finally, the SSLStatus event provides information about the SSL handshake.
The NNTPS bean implements a standard Usenet news reader as specified in RFC 977. It can be used to browse Usenet news groups and read and post articles.
The CurrentGroup property sets the current newsgroup. From then on, news articles from that
group can be read by setting the article number in CurrentArticle and
then calling the appropriate method. Properties such as ArticleCount , FirstArticle , LastArticle provide information about
the current state.
The headers and text of the articles are received respectively through the Header and Transfer events. Additionally, up to MaxLines from the article body are provided
in the ArticleText property. The GroupOverview event returns
information about a range of articles ( OverviewRange ) in CurrentGroup ,
and the GroupList event is used when listing newsgroup names. The PITrail event provides a trace of the interaction with the server.
The bean supports posting of articles through the ArticleText and AttachedFile properties. The article text is specified in one or both
of the above, and then the PostArticle method is called.
Article headers are given in a series of properties
like ArticleFrom , ArticleSubject , Organization , etc. that map directly to the
USENET article header with the same name.
| Field Summary | |
static int |
fwNone
|
static int |
fwSOCKS4
|
static int |
fwSOCKS5
|
static int |
fwTunnel
|
static int |
sslAutomatic
|
static int |
sslExplicit
|
static int |
sslImplicit
|
static int |
sslNone
|
static int |
sstMachine
|
static int |
sstPEMKey
|
static int |
sstPFXBlob
|
static int |
sstPFXFile
|
static int |
sstUser
|
| Constructor Summary | |
Nntps()
|
|
| Method Summary | |
void |
addNntpsEventListener(NntpsEventListener l)
|
java.lang.String |
config(java.lang.String configurationString)
Sets or retrieves a beanconfiguration setting. |
void |
connect()
Connect to the news server. |
void |
disconnect()
Disconnect from the news server. |
void |
doEvents()
Processes events from the internal message queue. |
void |
fetchArticle()
Get the headers and body of an article specified in CurrentArticle . |
void |
fetchArticleBody()
Get only the body of an article specified in CurrentArticle . |
void |
fetchArticleHeaders()
Get only the headers of an article specified in CurrentArticle . |
int |
getArticleCount()
The estimated number of articles in CurrentGroup . |
java.lang.String |
getArticleDate()
The date of the current article. |
java.lang.String |
getArticleFrom()
The email address of the author (for posting articles). |
java.lang.String |
getArticleHeaders()
The full headers of the article as retrieved from the server. |
java.lang.String |
getArticleId()
The message-id of the current article. |
java.lang.String |
getArticleReferences()
Articles the posted article follows up to. |
java.lang.String |
getArticleReplyTo()
The address to reply to (for posting articles). |
java.lang.String |
getArticleSubject()
The article subject (for posted articles). |
java.lang.String |
getArticleText()
The full text of the article (without the headers). |
java.lang.String |
getAttachedFile()
A file name of which the contents will be appended to ArticleText when posting articles. |
java.lang.String |
getCheckDate()
The date (format YYMMDD HHMMSS) to check for creation of new groups. |
java.lang.String |
getCurrentArticle()
The number or message-id of the current article. |
java.lang.String |
getCurrentGroup()
The name of the current group. |
java.lang.String |
getFirewallHost()
Name or IP address of firewall (optional). |
java.lang.String |
getFirewallPassword()
A password if authentication is to be used when connecting through the firewall. |
int |
getFirewallPort()
Port of the firewall to connect to. |
int |
getFirewallType()
Determines the type of firewall to connect through. |
java.lang.String |
getFirewallUser()
A user name if authentication is to be used connecting through a firewall. |
int |
getFirstArticle()
The number of the first article in CurrentGroup. |
int |
getLastArticle()
The number of the last article in CurrentGroup . |
java.lang.String |
getLastReply()
The last reply from the server. |
java.lang.String |
getLocalHost()
The name of the local host or user-assigned IP interface through which connections are initiated or accepted. |
int |
getMaxLines()
The maximum number of message lines besides headers to retrieve. |
java.lang.String |
getNewsgroups()
A comma separated list of newsgroups in which to post the article. |
int |
getNewsPort()
The server port for secure NNTP (default 563). |
java.lang.String |
getNewsServer()
The name or address of a news server. |
java.lang.String |
getOrganization()
The organization of the author (for posting articles). |
java.lang.String |
getOtherHeaders()
An RFC850 compliant string consisting of extra headers (for posting articles). |
java.lang.String |
getOverviewRange()
A range for the GroupOverview method (first-last). |
java.lang.String |
getPassword()
A login password to login with in the NewsServer . |
java.lang.String |
getSearchHeader()
A header for the GroupSearch method. |
java.lang.String |
getSearchPattern()
A search pattern for the GroupSearch method. |
java.lang.String |
getSearchRange()
A range for the GroupSearch method (first-last). |
byte[] |
getSSLAcceptServerCert()
Instructs the bean to unconditionally accept the server certificate that matches the supplied certificate. |
byte[] |
getSSLCertEncoded()
The SSL certificate (PEM/base64 encoded). |
byte[] |
getSSLCertStore()
The name of the certificate store for the client certificate. |
java.lang.String |
getSSLCertStorePassword()
The password for the certificate store (if any). |
int |
getSSLCertStoreType()
The type of certificate store for the client certificate. |
java.lang.String |
getSSLCertSubject()
The subject of the certificate used for client authentication. |
byte[] |
getSSLServerCert()
The server certificate for the last established connection. |
java.lang.String |
getSSLServerCertStatus()
The verification status of the server certificate for the last established connection. |
int |
getSSLStartMode()
Determines how the bean starts the SSL negotiation. |
int |
getTimeout()
A timeout for the bean. |
java.lang.String |
getUser()
A user id to login as in the NewsServer . |
void |
groupOverview()
Receive an overview for the articles in range OverviewRange in the CurrentGroup . |
void |
groupSearch()
Receive an overview for the articles in range OverviewRange in the CurrentGroup . |
void |
interrupt()
Interrupt the current method. |
boolean |
isConnected()
Shows whether the bean is connected. |
boolean |
isIdle()
The current status of the component. |
void |
listGroups()
List all groups on the server. |
void |
listNewGroups()
List all new groups on the server. |
java.lang.String |
localizeDate(java.lang.String dateTime)
Converts a valid RFC 822 message date to local date and time. |
void |
postArticle()
Post the current article and attached file. |
void |
removeNntpsEventListener(NntpsEventListener l)
|
void |
resetHeaders()
Reset all of the article headers. |
void |
setArticleFrom(java.lang.String articleFrom)
The email address of the author (for posting articles). |
void |
setArticleReferences(java.lang.String articleReferences)
Articles the posted article follows up to. |
void |
setArticleReplyTo(java.lang.String articleReplyTo)
The address to reply to (for posting articles). |
void |
setArticleSubject(java.lang.String articleSubject)
The article subject (for posted articles). |
void |
setArticleText(java.lang.String articleText)
The full text of the article (without the headers). |
void |
setAttachedFile(java.lang.String attachedFile)
A file name of which the contents will be appended to ArticleText when posting articles. |
void |
setCheckDate(java.lang.String checkDate)
The date (format YYMMDD HHMMSS) to check for creation of new groups. |
void |
setCommand(java.lang.String command)
Can be used to send additional commands directly to the server. |
void |
setConnected(boolean connected)
Shows whether the bean is connected. |
void |
setCurrentArticle(java.lang.String currentArticle)
The number or message-id of the current article. |
void |
setCurrentGroup(java.lang.String currentGroup)
The name of the current group. |
void |
setFirewallHost(java.lang.String firewallHost)
Name or IP address of firewall (optional). |
void |
setFirewallPassword(java.lang.String firewallPassword)
A password if authentication is to be used when connecting through the firewall. |
void |
setFirewallPort(int firewallPort)
Port of the firewall to connect to. |
void |
setFirewallType(int firewallType)
Determines the type of firewall to connect through. |
void |
setFirewallUser(java.lang.String firewallUser)
A user name if authentication is to be used connecting through a firewall. |
void |
setLocalHost(java.lang.String localHost)
The name of the local host or user-assigned IP interface through which connections are initiated or accepted. |
void |
setMaxLines(int maxLines)
The maximum number of message lines besides headers to retrieve. |
void |
setNewsgroups(java.lang.String newsgroups)
A comma separated list of newsgroups in which to post the article. |
void |
setNewsPort(int newsPort)
The server port for secure NNTP (default 563). |
void |
setNewsServer(java.lang.String newsServer)
The name or address of a news server. |
void |
setOrganization(java.lang.String organization)
The organization of the author (for posting articles). |
void |
setOtherHeaders(java.lang.String otherHeaders)
An RFC850 compliant string consisting of extra headers (for posting articles). |
void |
setOverviewRange(java.lang.String overviewRange)
A range for the GroupOverview method (first-last). |
void |
setPassword(java.lang.String password)
A login password to login with in the NewsServer . |
void |
setSearchHeader(java.lang.String searchHeader)
A header for the GroupSearch method. |
void |
setSearchPattern(java.lang.String searchPattern)
A search pattern for the GroupSearch method. |
void |
setSearchRange(java.lang.String searchRange)
A range for the GroupSearch method (first-last). |
void |
setSSLAcceptServerCert(byte[] SSLAcceptServerCert)
Instructs the bean to unconditionally accept the server certificate that matches the supplied certificate. |
void |
setSSLCertEncoded(byte[] SSLCertEncoded)
The SSL certificate (PEM/base64 encoded). |
void |
setSSLCertStore(byte[] SSLCertStore)
The name of the certificate store for the client certificate. |
void |
setSSLCertStorePassword(java.lang.String SSLCertStorePassword)
The password for the certificate store (if any). |
void |
setSSLCertStoreType(int SSLCertStoreType)
The type of certificate store for the client certificate. |
void |
setSSLCertSubject(java.lang.String SSLCertSubject)
The subject of the certificate used for client authentication. |
void |
setSSLStartMode(int SSLStartMode)
Determines how the bean starts the SSL negotiation. |
void |
setTimeout(int timeout)
A timeout for the bean. |
void |
setUser(java.lang.String user)
A user id to login as in the NewsServer . |
| Methods inherited from class java.lang.Object |
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait |
| Field Detail |
public static final int fwNone
public static final int fwTunnel
public static final int fwSOCKS4
public static final int fwSOCKS5
public static final int sstUser
public static final int sstMachine
public static final int sstPFXFile
public static final int sstPFXBlob
public static final int sstPEMKey
public static final int sslAutomatic
public static final int sslImplicit
public static final int sslExplicit
public static final int sslNone
| Constructor Detail |
public Nntps()
| Method Detail |
public int getArticleCount()
CurrentGroup .
The value of this property is 0 if there is no current
group ( CurrentGroup is ""). Otherwise, it is the
number of articles in the group as shown by the news
server when CurrentGroup is set. For most
news servers, this is an estimated value of the
number of the articles, rather than the exact value.
public java.lang.String getArticleDate()
If the bean is not connected or CurrentArticle is empty, the value of this property is an
empty string. Otherwise, it contains the date of the article as reported by the server.
The NewsServer is asked about the headers of the article only if the CurrentArticle property has
changed. If CurrentArticle has not changed, the bean returns a cached value.
public java.lang.String getArticleFrom()
The string in ArticleFrom is posted with a From article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleFrom(java.lang.String articleFrom)
throws IPWorksSSLException
The string in ArticleFrom is posted with a From article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksSSLExceptionpublic java.lang.String getArticleHeaders()
If the bean is not connected or CurrentArticle is empty,
the value of this property is an
empty string. Otherwise, it contains the full headers of the article
as reported by the server.
The NewsServer is asked about the headers of the article only
if the CurrentArticle property has changed. If CurrentArticle has not changed, the bean returns a cached value.
public java.lang.String getArticleId()
If the bean is not connected or CurrentArticle is empty, the value of this property is an
empty string. Otherwise, it contains the message-id of the article as reported by the server.
The NewsServer is asked about the headers of the article only if the CurrentArticle property has
changed. If CurrentArticle has not changed, the bean returns a cached value.
public java.lang.String getArticleReferences()
If the ArticleReferences property contains a non-empty string,
a References article header is created for the article.
This header shows the article-ids the posted article refers
to.
The references must be separated by space characters.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleReferences(java.lang.String articleReferences)
throws IPWorksSSLException
If the ArticleReferences property contains a non-empty string,
a References article header is created for the article.
This header shows the article-ids the posted article refers
to.
The references must be separated by space characters.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksSSLExceptionpublic java.lang.String getArticleReplyTo()
If the ArticleReplyTo property contains a non-empty string,
a Reply-To article header is created for the article.
This header shows the address to use for replies (useful
if this address is different from the one in ArticleFrom ).
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleReplyTo(java.lang.String articleReplyTo)
throws IPWorksSSLException
If the ArticleReplyTo property contains a non-empty string,
a Reply-To article header is created for the article.
This header shows the address to use for replies (useful
if this address is different from the one in ArticleFrom ).
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksSSLExceptionpublic java.lang.String getArticleSubject()
The string in ArticleSubject is posted with a Subject article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setArticleSubject(java.lang.String articleSubject)
throws IPWorksSSLException
The string in ArticleSubject is posted with a Subject article header to the news server.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksSSLExceptionpublic java.lang.String getArticleText()
If the bean is not connected or CurrentArticle is empty,
the value of this property is an
empty string. Otherwise, it contains the full text of the article
as reported by the server.
The NewsServer is asked about the text of the article only
if the CurrentArticle property has changed. If CurrentArticle has not changed, the bean returns a cached value.
When posting articles, the ArticleText property contains the full text of
the article to post.
It is advisable that the text contained in this property be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the article lines must contain 7-bit characters so that the article can be successfully transferred through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another "." as specified in RFC 977. The article text is unescaped by the news server, so the process is fully transparent.
public void setArticleText(java.lang.String articleText)
throws IPWorksSSLException
If the bean is not connected or CurrentArticle is empty,
the value of this property is an
empty string. Otherwise, it contains the full text of the article
as reported by the server.
The NewsServer is asked about the text of the article only
if the CurrentArticle property has changed. If CurrentArticle has not changed, the bean returns a cached value.
When posting articles, the ArticleText property contains the full text of
the article to post.
It is advisable that the text contained in this property be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the article lines must contain 7-bit characters so that the article can be successfully transferred through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another "." as specified in RFC 977. The article text is unescaped by the news server, so the process is fully transparent.
IPWorksSSLExceptionpublic java.lang.String getAttachedFile()
The content of AttachedFile is appended to the text
in ArticleText (if any) and sent to the news server.
This property is useful for posting arbitrarily large
articles and/or sending MIME attachments.
It is advisable that the text contained in the file be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the message lines must contain only 7-bit characters so that the message may be successfully sent through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another as specified in RFC 822. The article text is unescaped by the news server, so the process is fully transparent.
public void setAttachedFile(java.lang.String attachedFile)
throws IPWorksSSLException
The content of AttachedFile is appended to the text
in ArticleText (if any) and sent to the news server.
This property is useful for posting arbitrarily large
articles and/or sending MIME attachments.
It is advisable that the text contained in the file be a collection of lines with lengths less than or equal to 80 bytes separated by CRLF ("\\r\\n") . The text in the message lines must contain only 7-bit characters so that the message may be successfully sent through the various Usenet news servers on the Internet.
The bean automatically escapes lines that start with a "." by adding another as specified in RFC 822. The article text is unescaped by the news server, so the process is fully transparent.
IPWorksSSLExceptionpublic java.lang.String getCheckDate()
The value of this property is used as an argument for
the ListNewGroups method.
public void setCheckDate(java.lang.String checkDate)
throws IPWorksSSLException
The value of this property is used as an argument for
the ListNewGroups method.
IPWorksSSLException
public void setCommand(java.lang.String command)
throws IPWorksSSLException
Check the LastReply property and/or trap the PITrail events
coming from the server to get the response.
IPWorksSSLExceptionpublic boolean isConnected()
Use this property to determine whether the bean is connected to the remote host or not.
public void setConnected(boolean connected)
throws IPWorksSSLException
Use this property to determine whether the bean is connected to the remote host or not.
IPWorksSSLExceptionpublic java.lang.String getCurrentArticle()
The CurrentArticle property specifies either
a message id or an article number uniquely identifying
a particular article. It is then used as an argument
to methods such as FetchArticle .
public void setCurrentArticle(java.lang.String currentArticle)
throws IPWorksSSLException
The CurrentArticle property specifies either
a message id or an article number uniquely identifying
a particular article. It is then used as an argument
to methods such as FetchArticle .
IPWorksSSLExceptionpublic java.lang.String getCurrentGroup()
When the CurrentGroup property is set to a valid
group name, the bean sends an NNTP GROUP command to the NewsServer and enters the specified
group. If the command is successful, FirstArticle , LastArticle , and ArticleCount are set to the
reported values for the group. CurrentGroup is then
used for all references to articles (until changed to
another group).
public void setCurrentGroup(java.lang.String currentGroup)
throws IPWorksSSLException
When the CurrentGroup property is set to a valid
group name, the bean sends an NNTP GROUP command to the NewsServer and enters the specified
group. If the command is successful, FirstArticle , LastArticle , and ArticleCount are set to the
reported values for the group. CurrentGroup is then
used for all references to articles (until changed to
another group).
IPWorksSSLExceptionpublic java.lang.String getFirewallHost()
If a FirewallHost is given, requested connections will be
authenticated through the specified firewall when connecting.
If the FirewallHost property is set to a Domain Name, a DNS request
is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the
search is not successful, an error is returned.
public void setFirewallHost(java.lang.String firewallHost)
throws IPWorksSSLException
If a FirewallHost is given, requested connections will be
authenticated through the specified firewall when connecting.
If the FirewallHost property is set to a Domain Name, a DNS request
is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the
search is not successful, an error is returned.
IPWorksSSLExceptionpublic java.lang.String getFirewallPassword()
if FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate
to the given firewall. If the authentication fails, a trappable error is fired.
public void setFirewallPassword(java.lang.String firewallPassword)
throws IPWorksSSLException
if FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate
to the given firewall. If the authentication fails, a trappable error is fired.
IPWorksSSLExceptionpublic int getFirewallPort()
The TCP port for the FirewallHost . See the
description of the FirewallHost property for
details.
Note that the FirewallPort is set automatically
when FirewallType is set to a valid value. See the
description of the FirewallType property for
details.
public void setFirewallPort(int firewallPort)
throws IPWorksSSLException
The TCP port for the FirewallHost . See the
description of the FirewallHost property for
details.
Note that the FirewallPort is set automatically
when FirewallType is set to a valid value. See the
description of the FirewallType property for
details.
IPWorksSSLExceptionpublic int getFirewallType()
The applicable values are the following:
FirewallPort is set to 80.
FirewallPort is set to 1080.
FirewallPort is set to 1080.
public void setFirewallType(int firewallType)
throws IPWorksSSLException
The applicable values are the following:
FirewallPort is set to 80.
FirewallPort is set to 1080.
FirewallPort is set to 1080.
IPWorksSSLExceptionpublic java.lang.String getFirewallUser()
if FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate
to the given firewall. If the authentication fails, a trappable error is fired.
public void setFirewallUser(java.lang.String firewallUser)
throws IPWorksSSLException
if FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate
to the given firewall. If the authentication fails, a trappable error is fired.
IPWorksSSLExceptionpublic int getFirstArticle()
The value of this property is 0 if there is no current
group ( CurrentGroup is "").
public boolean isIdle()
Idle will be False if the component is currently busy (communicating
and/or waiting for an answer), and True at all other times.
public int getLastArticle()
CurrentGroup .
The value of this property is 0 if there is no current
group ( CurrentGroup is "").
public java.lang.String getLastReply()
This is the last reply received from the server. It
can be used for information purposes. The same information
and more can also be retrieved through the PITrail event.
public java.lang.String getLocalHost()
The LocalHost property contains the name of the local host
as obtained by the gethostname() system call, or if the
user has assigned an IP address, the value of that address.
In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the bean initiate connections (or accept in the case of server beans) only through that interface.
If the bean is connected, the LocalHost property shows
the IP address of the interface through which the connection
is made in internet dotted format (aaa.bbb.ccc.ddd). In most
cases, this is the address of the local host, except for multihomed
hosts (machines with more than one IP interface).
NOTE: LocalHost is not persistent. You must always set it in
code, and never in the property window.
public void setLocalHost(java.lang.String localHost)
throws IPWorksSSLException
The LocalHost property contains the name of the local host
as obtained by the gethostname() system call, or if the
user has assigned an IP address, the value of that address.
In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the bean initiate connections (or accept in the case of server beans) only through that interface.
If the bean is connected, the LocalHost property shows
the IP address of the interface through which the connection
is made in internet dotted format (aaa.bbb.ccc.ddd). In most
cases, this is the address of the local host, except for multihomed
hosts (machines with more than one IP interface).
NOTE: LocalHost is not persistent. You must always set it in
code, and never in the property window.
IPWorksSSLExceptionpublic int getMaxLines()
The MaxLines property is used to limit the number
of text lines besides headers retrieved for messages.
This property is used in conjunction with the ArticleText property. Please note that due to NNTP protocol limitations,
the full text of the article
is always retrieved from the server, but only MaxLines will be stored in ArticleText .
The default value of the property is 0. In this case the entire message will be retrieved, without interruptions.
public void setMaxLines(int maxLines)
throws IPWorksSSLException
The MaxLines property is used to limit the number
of text lines besides headers retrieved for messages.
This property is used in conjunction with the ArticleText property. Please note that due to NNTP protocol limitations,
the full text of the article
is always retrieved from the server, but only MaxLines will be stored in ArticleText .
The default value of the property is 0. In this case the entire message will be retrieved, without interruptions.
IPWorksSSLExceptionpublic java.lang.String getNewsgroups()
The string in Newsgroups is posted with a Newsgroups article header to the news server. It specifies the list
of groups where the article is posted (comma separated).
If the Newsgroups property contains "" (empty string), then
the value of the CurrentGroup property is used to specify
the target newsgroup for the posted article.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setNewsgroups(java.lang.String newsgroups)
throws IPWorksSSLException
The string in Newsgroups is posted with a Newsgroups article header to the news server. It specifies the list
of groups where the article is posted (comma separated).
If the Newsgroups property contains "" (empty string), then
the value of the CurrentGroup property is used to specify
the target newsgroup for the posted article.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksSSLExceptionpublic int getNewsPort()
A valid port number (a value between 1 and 65535) is required for the connection to take place. The property must be set before a connection is attempted and cannot be changed once a connection is established. Any attempt to change this property while connected will fail with an error.
public void setNewsPort(int newsPort)
throws IPWorksSSLException
A valid port number (a value between 1 and 65535) is required for the connection to take place. The property must be set before a connection is attempted and cannot be changed once a connection is established. Any attempt to change this property while connected will fail with an error.
IPWorksSSLExceptionpublic java.lang.String getNewsServer()
The NewsServer property specifies the IP address (IP number in
dotted internet format) or Domain Name for the news server. It is
set before a connection is attempted and cannot be changed once
a connection is in progress.
If the NewsServer property is set to a Domain Name, a DNS request
is initiated and upon successful termination of the request, the NewsServer property is set to the corresponding address. If the
search is not successful, an error is returned.
If the bean is configured to use a SOCKS firewall, the value assigned to this property may be preceded with a "*". If this is the case, the host name is passed to the firewall unresolved and the firewall performs the DNS resolution.
public void setNewsServer(java.lang.String newsServer)
throws IPWorksSSLException
The NewsServer property specifies the IP address (IP number in
dotted internet format) or Domain Name for the news server. It is
set before a connection is attempted and cannot be changed once
a connection is in progress.
If the NewsServer property is set to a Domain Name, a DNS request
is initiated and upon successful termination of the request, the NewsServer property is set to the corresponding address. If the
search is not successful, an error is returned.
If the bean is configured to use a SOCKS firewall, the value assigned to this property may be preceded with a "*". If this is the case, the host name is passed to the firewall unresolved and the firewall performs the DNS resolution.
IPWorksSSLExceptionpublic java.lang.String getOrganization()
If the Organization property contains a non-empty string,
an Organization article header is created for the article.
This header shows the organization of the author and is used
for information purposes only.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
public void setOrganization(java.lang.String organization)
throws IPWorksSSLException
If the Organization property contains a non-empty string,
an Organization article header is created for the article.
This header shows the organization of the author and is used
for information purposes only.
If the resulting header is longer thanMaxHeaderLength, then it is folded according to RFC 850 specifications.
IPWorksSSLExceptionpublic java.lang.String getOtherHeaders()
The OtherHeaders property contains a string of headers
to be appended to the message headers created from other
properties like From , Subject , etc.
The headers must be of the format "header: value" as specified in RFC 850. [Header lines should be separated by CRLF ("\\r\\n") .
Use this property with caution. If OtherHeaders contains
invalid headers, article posting might not be successful.
The OtherHeaders property is useful for extending the
functionality of the bean. A good example is posting of
MIME attachments.
SPECIAL CASE: if OtherHeaders starts with an empty line (CRLF),
then the value of OtherHeaders is used instead of the normally
computed article headers.
public void setOtherHeaders(java.lang.String otherHeaders)
throws IPWorksSSLException
The OtherHeaders property contains a string of headers
to be appended to the message headers created from other
properties like From , Subject , etc.
The headers must be of the format "header: value" as specified in RFC 850. [Header lines should be separated by CRLF ("\\r\\n") .
Use this property with caution. If OtherHeaders contains
invalid headers, article posting might not be successful.
The OtherHeaders property is useful for extending the
functionality of the bean. A good example is posting of
MIME attachments.
SPECIAL CASE: if OtherHeaders starts with an empty line (CRLF),
then the value of OtherHeaders is used instead of the normally
computed article headers.
IPWorksSSLExceptionpublic java.lang.String getOverviewRange()
GroupOverview method (first-last).
The OverviewRange specifies a range of articles
for which to retrieve article overviews from the server. The format
is 'first-last' where first is "" (empty string) or
a positive number, and last is "" (empty string), a positive
number, or the token end .
The default value of the property is '-', meaning 'all articles in the group' .
public void setOverviewRange(java.lang.String overviewRange)
throws IPWorksSSLException
GroupOverview method (first-last).
The OverviewRange specifies a range of articles
for which to retrieve article overviews from the server. The format
is 'first-last' where first is "" (empty string) or
a positive number, and last is "" (empty string), a positive
number, or the token end .
The default value of the property is '-', meaning 'all articles in the group' .
IPWorksSSLExceptionpublic java.lang.String getPassword()
NewsServer .
If the Password property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO PASS
command is sent in order to provide authentication
information for the user. This command is not part
of the NNTP protocol, but it is widely used by popular
news servers.
public void setPassword(java.lang.String password)
throws IPWorksSSLException
NewsServer .
If the Password property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO PASS
command is sent in order to provide authentication
information for the user. This command is not part
of the NNTP protocol, but it is widely used by popular
news servers.
IPWorksSSLExceptionpublic java.lang.String getSearchHeader()
GroupSearch method.
The SearchHeader property specifies the header to search
for SearchPattern (e.g. "Subject").
public void setSearchHeader(java.lang.String searchHeader)
throws IPWorksSSLException
GroupSearch method.
The SearchHeader property specifies the header to search
for SearchPattern (e.g. "Subject").
IPWorksSSLExceptionpublic java.lang.String getSearchPattern()
GroupSearch method.
The format of the pattern is the same as the patterns used by the UNIX 'find' command.
As an example, "* new *" will match all headers that contain the word "new".
public void setSearchPattern(java.lang.String searchPattern)
throws IPWorksSSLException
GroupSearch method.
The format of the pattern is the same as the patterns used by the UNIX 'find' command.
As an example, "* new *" will match all headers that contain the word "new".
IPWorksSSLExceptionpublic java.lang.String getSearchRange()
GroupSearch method (first-last).
The SearchRange specifies a range of articles for which to do a search on the server. The format is 'first-last' where first is "" (empty string) or a positive number, and last is "" (empty string), a positive number, or the token end .
The default value of the property is '-', meaning 'search all articles in the group' .
public void setSearchRange(java.lang.String searchRange)
throws IPWorksSSLException
GroupSearch method (first-last).
The SearchRange specifies a range of articles for which to do a search on the server. The format is 'first-last' where first is "" (empty string) or a positive number, and last is "" (empty string), a positive number, or the token end .
The default value of the property is '-', meaning 'search all articles in the group' .
IPWorksSSLExceptionpublic byte[] getSSLAcceptServerCert()
If it finds any issues with the certificate presented by the server, the bean will normally terminate the connection with an error.
You may override this behavior by supplying a value for SSLAcceptServerCert .
If the certificate supplied in SSLAcceptServerCert is the same as the
certificate presented by the server, then the server
certificate is accepted unconditionally, and the connection will continue
normally.
Please note that this functionality is provided only for cases where you otherwise know that you are communicating with the right server. If used improperly, these property will create a security breach. Use it at your own risk.
public void setSSLAcceptServerCert(byte[] SSLAcceptServerCert)
throws IPWorksSSLException
If it finds any issues with the certificate presented by the server, the bean will normally terminate the connection with an error.
You may override this behavior by supplying a value for SSLAcceptServerCert .
If the certificate supplied in SSLAcceptServerCert is the same as the
certificate presented by the server, then the server
certificate is accepted unconditionally, and the connection will continue
normally.
Please note that this functionality is provided only for cases where you otherwise know that you are communicating with the right server. If used improperly, these property will create a security breach. Use it at your own risk.
IPWorksSSLExceptionpublic byte[] getSSLCertEncoded()
This property is used to assign a specific certificate for
SSL client authentication (SSL server authentication in
the case of the IPDaemonS bean).
The SSLCertStore and SSLCertSubject properties may also be used to specify a certificate.
When SSLCertEncoded is set, a search is initiated in the current SSLCertStore for the private key of the certificate. If the key
is found, SSLCertSubject is updated to reflect the full subject
of the selected certificate, otherwise SSLCertSubject is set
to empty string.
public void setSSLCertEncoded(byte[] SSLCertEncoded)
throws IPWorksSSLException
This property is used to assign a specific certificate for
SSL client authentication (SSL server authentication in
the case of the IPDaemonS bean).
The SSLCertStore and SSLCertSubject properties may also be used to specify a certificate.
When SSLCertEncoded is set, a search is initiated in the current SSLCertStore for the private key of the certificate. If the key
is found, SSLCertSubject is updated to reflect the full subject
of the selected certificate, otherwise SSLCertSubject is set
to empty string.
IPWorksSSLExceptionpublic byte[] getSSLCertStore()
The SSLCertStoreType property specifies the type of the
certificate store specified by SSLCertStore . If the store
is password protected, specify the password in SSLCertStorePassword .
SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject or SSLCertEncoded is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.
Designations of certificate stores are platform-dependent.
The following are designations of the most common User and Machine certificate stores in Windows:
In Java, the certificate store normally is a file containing certificates and optional private keys.
When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).
If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.
public void setSSLCertStore(byte[] SSLCertStore)
throws IPWorksSSLException
The SSLCertStoreType property specifies the type of the
certificate store specified by SSLCertStore . If the store
is password protected, specify the password in SSLCertStorePassword .
SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject or SSLCertEncoded is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.
Designations of certificate stores are platform-dependent.
The following are designations of the most common User and Machine certificate stores in Windows:
In Java, the certificate store normally is a file containing certificates and optional private keys.
When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).
If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.
IPWorksSSLExceptionpublic java.lang.String getSSLCertStorePassword()
If the certificate store is of a type that requires a password, the value of this property is used to open the certificate store.
public void setSSLCertStorePassword(java.lang.String SSLCertStorePassword)
throws IPWorksSSLException
If the certificate store is of a type that requires a password, the value of this property is used to open the certificate store.
IPWorksSSLExceptionpublic int getSSLCertStoreType()
This property can take one of the following values:
public void setSSLCertStoreType(int SSLCertStoreType)
throws IPWorksSSLException
This property can take one of the following values:
IPWorksSSLExceptionpublic java.lang.String getSSLCertSubject()
When this property is set, a search is performed in the current certificate store certificate with matching subject.
If an exact match is not found, the store is searched for subjects containing the value of the property.
When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US
Example (Searching with partial subject)
Control.CertSubject = "Test"
If a match is not found, the property is set to an empty string, and no certificate is selected.
The special value "*" picks a random certificate in the certificate store.
If a matching certificate is found, the SSLCertSubject property
is set to the full subject of the matching certificate.
public void setSSLCertSubject(java.lang.String SSLCertSubject)
throws IPWorksSSLException
When this property is set, a search is performed in the current certificate store certificate with matching subject.
If an exact match is not found, the store is searched for subjects containing the value of the property.
When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US
Example (Searching with partial subject)
Control.CertSubject = "Test"
If a match is not found, the property is set to an empty string, and no certificate is selected.
The special value "*" picks a random certificate in the certificate store.
If a matching certificate is found, the SSLCertSubject property
is set to the full subject of the matching certificate.
IPWorksSSLExceptionpublic byte[] getSSLServerCert()
SSLServerCert contains the server certificate for the
last established connection.
SSLServerCert is reset every time a new connection is attempted.
public java.lang.String getSSLServerCertStatus()
When the verification fails, SSLServerCertStatus contains
a string that indicates the reason(s) why, otherwise, it
contains the string "OK".
Please note that the value of SSLServerCertStatus must
be considered as only a suggestion as to the validity of the
certificate. Application software must use its own logic
to determine whether to accept the certificate or not, by using
the SSLServerCert to access other certificate
properties, or other application-specific information.
SSLServerCertStatus is reset an empty string every time a new
connection is attempted.
public int getSSLStartMode()
The SSLStartMode property may have one of the following values:
SSLStartMode is set to sslExplicit . In all other cases, SSL negotiation will be implicit
( sslImplicit ).
public void setSSLStartMode(int SSLStartMode)
throws IPWorksSSLException
The SSLStartMode property may have one of the following values:
SSLStartMode is set to sslExplicit . In all other cases, SSL negotiation will be implicit
( sslImplicit ).
IPWorksSSLExceptionpublic int getTimeout()
If the Timeout property is set to 0, all operations
will run uninterrupted until successful completion, or an error condition
is encountered.
If Timeout is set to a positive value, the bean will
wait for the operation to complete before returning control.
The bean will use DoEvents to enter an efficient wait loop
during any potential waiting period, making sure that all system events
are processed immediately as they arrive. This ensures that the host
application does not "freeze" and remains responsive.
If Timeout expires, and the operation is not yet complete,
the bean throws an IPWorksException
raises an IPWorksException exception
.
Please note that by default, all timeouts are inactivity timeouts ,
i.e. the timeout period is extended by Timeout seconds when
data is successfully sent or received.
Optionally, the behavior of the bean may be changed to absolute timeouts , i.e. the bean will wait for a maximum
of Timeout seconds since the beginning of the operation, without
extending the timeout period during communications.
This behavior is controlled by theAbsoluteTimeoutconfiguration setting.
The default value for the Timeout property is 60 (seconds).
public void setTimeout(int timeout)
throws IPWorksSSLException
If the Timeout property is set to 0, all operations
will run uninterrupted until successful completion, or an error condition
is encountered.
If Timeout is set to a positive value, the bean will
wait for the operation to complete before returning control.
The bean will use DoEvents to enter an efficient wait loop
during any potential waiting period, making sure that all system events
are processed immediately as they arrive. This ensures that the host
application does not "freeze" and remains responsive.
If Timeout expires, and the operation is not yet complete,
the bean throws an IPWorksException
raises an IPWorksException exception
.
Please note that by default, all timeouts are inactivity timeouts ,
i.e. the timeout period is extended by Timeout seconds when
data is successfully sent or received.
Optionally, the behavior of the bean may be changed to absolute timeouts , i.e. the bean will wait for a maximum
of Timeout seconds since the beginning of the operation, without
extending the timeout period during communications.
This behavior is controlled by theAbsoluteTimeoutconfiguration setting.
The default value for the Timeout property is 60 (seconds).
IPWorksSSLExceptionpublic java.lang.String getUser()
NewsServer .
If the User property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO USER
command is sent in order to provide authentication
information for the user. Although this command is not part
of the NNTP protocol, it is widely used by news servers for
authentication purposes.
public void setUser(java.lang.String user)
throws IPWorksSSLException
NewsServer .
If the User property is set to a non-empty string,
then when connecting to the NewsServer an AUTHINFO USER
command is sent in order to provide authentication
information for the user. Although this command is not part
of the NNTP protocol, it is widely used by news servers for
authentication purposes.
IPWorksSSLException
public java.lang.String config(java.lang.String configurationString)
throws IPWorksSSLException
Config is a generic method available in every bean.
It is used to set and retrieveconfiguration settingsfor the
bean.
Configuration settings are similar in functionality to properties,
but they are rarely used. In order to avoid "polluting" the property
namespace of the bean, access to these internal properties is provided through the Config method.
To set a configuration setting named PROPERTY , you must call Config("PROPERTY=VALUE") , where VALUE is the value of the setting expressed as a string. For boolean values, use the strings "True", "False", "0", "1", "Yes", or "No" (case does not matter).
To read (query) the value of a configuration setting, you must call Config("PROPERTY") . The value will be returned as a string.
IPWorksSSLException
public void connect()
throws IPWorksSSLException
Connect to the news server. If the User and/or Password are set,
then corresponding AUTHINFO commands are sent to the NewsServer as well.
IPWorksSSLException
public void disconnect()
throws IPWorksSSLException
Disconnect from the NewsServer . First the bean attempts to send
a QUIT command, and if that fails, the connection is broken.
IPWorksSSLException
public void doEvents()
throws IPWorksSSLException
When DoEvents is called, the bean processes any
available events. If no events are available, it waits for a
preset period of time, and then returns.
IPWorksSSLException
public void fetchArticle()
throws IPWorksSSLException
CurrentArticle .
Get the headers and body of the article specified in CurrentArticle .
The headers are delivered via the Header event, and the article body
via the Transfer event.
If a connection to the NewsServer doesn't
already exist, a new one is created.
IPWorksSSLException
public void fetchArticleBody()
throws IPWorksSSLException
CurrentArticle .
Get only the body of the article specified in CurrentArticle .
The body via the Transfer event.
If a connection to the NewsServer doesn't already exist, a new one is created.
IPWorksSSLException
public void fetchArticleHeaders()
throws IPWorksSSLException
CurrentArticle .
Get only the headers of the article specified in CurrentArticle .
The headers are delivered via the Header event.
If a connection to the NewsServer doesn't already exist, a new
one is created.
IPWorksSSLException
public void groupOverview()
throws IPWorksSSLException
OverviewRange in the CurrentGroup .
Receive an overview for the articles in range OverviewRange in the CurrentGroup . The overview data is delivered via the GroupOverview event.
If a connection to the NewsServer doesn't already exist, a new
one is created.
IPWorksSSLException
public void groupSearch()
throws IPWorksSSLException
OverviewRange in the CurrentGroup .
Searches the current newsgroup for articles in range SearchRange in the CurrentGroup , where SearchHeader matches SearchPattern . The results
are delivered via the GroupSearch event.
If a connection to the NewsServer doesn't already exist, a new
one is created.
IPWorksSSLException
public void interrupt()
throws IPWorksSSLException
If there is no method in progress, Interrupt simply returns doing nothing.
IPWorksSSLException
public void listGroups()
throws IPWorksSSLException
Asks the server to list all its newsgroups. Use this method with
caution as listing groups may take quite a long over slow links. The group names and
other information are returned via the GroupList event.
If a connection to the NewsServer doesn't already exist, a new one
is created.
IPWorksSSLException
public void listNewGroups()
throws IPWorksSSLException
Asks the server to list all the newsgroups created since CheckDate .
The group names (if any) and other information are returned via the GroupList event.
If a connection to the NewsServer doesn't already exist,
a new one is created.
IPWorksSSLException
public java.lang.String localizeDate(java.lang.String dateTime)
throws IPWorksSSLException
This method can be used to convert an RFC 822 date/time string to the corresponding local date and time.
Dates will be returned in the format: "MM/dd/yyyy hh:mm:ss".
IPWorksSSLException
public void postArticle()
throws IPWorksSSLException
Post the current article and attached file (if any). If a connection to the NewsServer doesn't already exist, a new one is created.
IPWorksSSLException
public void resetHeaders()
throws IPWorksSSLException
Resets all the article headers to "" (empty string). Use this property before posting a new article, so that headers from the previous article are not carried over to the next one.
IPWorksSSLException
public void addNntpsEventListener(NntpsEventListener l)
throws java.util.TooManyListenersException
java.util.TooManyListenersExceptionpublic void removeNntpsEventListener(NntpsEventListener l)
|
IP*Works! SSL V6 | ||||||||
| PREV CLASS NEXT CLASS | FRAMES NO FRAMES | ||||||||
| SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD | ||||||||