1 00:00:00,000 --> 00:00:03,311 [AUDIO LOGO] 2 00:00:03,311 --> 00:00:08,050 3 00:00:08,050 --> 00:00:11,450 Congratulations on completing another skill. 4 00:00:11,450 --> 00:00:15,890 Now it's time for a review in the form of a quiz. 5 00:00:15,890 --> 00:00:19,730 Let's jump in with our first question. 6 00:00:19,730 --> 00:00:25,730 Type 1 external lSAs increase the metric on the LSA 7 00:00:25,730 --> 00:00:28,430 to account for internal costs. 8 00:00:28,430 --> 00:00:29,585 True or false? 9 00:00:29,585 --> 00:00:35,080 10 00:00:35,080 --> 00:00:38,070 So for this question, we have to look at the wording 11 00:00:38,070 --> 00:00:44,310 very carefully because Type 1 external LSAs do 12 00:00:44,310 --> 00:00:47,760 account for internal costs. 13 00:00:47,760 --> 00:00:50,460 That part is all correct. 14 00:00:50,460 --> 00:00:53,700 The part that's a problem is where 15 00:00:53,700 --> 00:00:58,290 it says that it increases the metric on the LSA. 16 00:00:58,290 --> 00:01:00,870 This is the part that's not true. 17 00:01:00,870 --> 00:01:06,330 The LSA is kept the same through the entire network. 18 00:01:06,330 --> 00:01:10,200 What happens is the receiving device 19 00:01:10,200 --> 00:01:16,560 then adds the metric to the cost to the advertising router, 20 00:01:16,560 --> 00:01:20,580 and those are added together not in the LSA 21 00:01:20,580 --> 00:01:22,380 but in the routing table. 22 00:01:22,380 --> 00:01:26,640 Therefore, that makes this overall answer false 23 00:01:26,640 --> 00:01:29,640 because we're not keeping the information in the LSA, 24 00:01:29,640 --> 00:01:34,170 it's being calculated and then put into the routing table. 25 00:01:34,170 --> 00:01:38,600 Next question, if you change auto-cost reference-bandwidth 26 00:01:38,600 --> 00:01:40,730 to 10,000. 27 00:01:40,730 --> 00:01:44,680 What would be the cost of a gigabit ethernet interface? 28 00:01:44,680 --> 00:01:50,190 29 00:01:50,190 --> 00:01:53,450 So what we need to remember for this question is 30 00:01:53,450 --> 00:01:55,910 the auto-cost reference-bandwidth 31 00:01:55,910 --> 00:01:58,140 is in megabits per second. 32 00:01:58,140 --> 00:02:00,710 So essentially what that means is that this would 33 00:02:00,710 --> 00:02:04,010 be 10,000 megabits per second. 34 00:02:04,010 --> 00:02:08,699 And of course, gigabit is 1,000 megabits per second, 35 00:02:08,699 --> 00:02:13,140 therefore number three would be our correct answer. 36 00:02:13,140 --> 00:02:16,630 It would be a cost of 10. 37 00:02:16,630 --> 00:02:20,380 Final question, which method of route selection 38 00:02:20,380 --> 00:02:27,350 does IOS XR use for its Type 5 versus Type 7 LSAs? 39 00:02:27,350 --> 00:02:33,350 40 00:02:33,350 --> 00:02:37,340 So what we're really talking about here is with the Type 5s 41 00:02:37,340 --> 00:02:41,660 these would be our E1s and E2s. 42 00:02:41,660 --> 00:02:47,660 With the Type 7s, these would be the N1s and the N2s. 43 00:02:47,660 --> 00:02:50,030 So what this question is really asking 44 00:02:50,030 --> 00:02:55,400 is on IOS XR which RFC do we use when 45 00:02:55,400 --> 00:03:00,890 determining if we prefer ease over ends or ends over ease? 46 00:03:00,890 --> 00:03:04,880 Now we can start off by very quickly eliminating 47 00:03:04,880 --> 00:03:09,560 RFC 2101 that has nothing to do with NSSA 48 00:03:09,560 --> 00:03:12,590 neither does RFC 7711. 49 00:03:12,590 --> 00:03:14,270 I don't even know what those two are. 50 00:03:14,270 --> 00:03:15,920 They're just made up answers. 51 00:03:15,920 --> 00:03:21,470 Now the two RFCs that are related to external versus NSSA 52 00:03:21,470 --> 00:03:25,850 are RFC 1587 and 3101. 53 00:03:25,850 --> 00:03:32,240 Remember the 1587 says to prefer E over N. 54 00:03:32,240 --> 00:03:35,120 And 3101, which is the newer method, 55 00:03:35,120 --> 00:03:38,090 says to prefer N over E. 56 00:03:38,090 --> 00:03:41,820 So the question becomes, as of right now, 57 00:03:41,820 --> 00:03:46,430 which of these methods is used by IOS XR. 58 00:03:46,430 --> 00:03:51,350 And unfortunately the answer is RFC 1587. 59 00:03:51,350 --> 00:03:54,360 I say unfortunately because it is the older method. 60 00:03:54,360 --> 00:04:00,500 However, keep in mind that NSSAs or Not-So-Stubby Areas are not 61 00:04:00,500 --> 00:04:04,280 necessarily the focus of iOS XR. 62 00:04:04,280 --> 00:04:06,560 That would of course, make answer three here 63 00:04:06,560 --> 00:04:08,270 an incorrect answer as well. 64 00:04:08,270 --> 00:04:13,140 That's not supported on IOS XR, at least not right now. 65 00:04:13,140 --> 00:04:20,380 So that leaves our correct answer as number two, RFC 1587. 66 00:04:20,380 --> 00:04:22,490 So that concludes this quiz. 67 00:04:22,490 --> 00:04:25,150 If you find that you are missing any of the information 68 00:04:25,150 --> 00:04:27,520 here to answer these questions, I 69 00:04:27,520 --> 00:04:29,830 would encourage you to go back and review the reference 70 00:04:29,830 --> 00:04:32,360 sources on each question. 71 00:04:32,360 --> 00:04:37,510 Otherwise, congratulations on completing OSPF path selection. 72 00:04:37,510 --> 00:04:39,850 I hope this has been informative for you, 73 00:04:39,850 --> 00:04:42,960 and I'd like to thank you for viewing. 74 00:04:42,960 --> 00:04:46,000