2.3.1.2 peditw.exe

The peditw.exe is a visual application for Windows used for creating, converting, editing and sorting functions.
The F8 key is used to add a new entry into the database.
Figure 11
The new entry can be added to database by pressing the Enter key, or can be cancelled by pressing the Esc or the F5 key. The selected entry can be deleted using the F4 key. The * in the title indicates that are unsaved changes.
After making any changes in the database, the “Save as…” becomes available, and the database can be saved.
The F9 key is for converting the database into a printable text format. A popup message will show the location of the file which has been created.
The output will be a .txt file which contains the database sorted by name. Each field within an entry is separated with a semicolon. This format is compatible with any CSV reader. The information from the fields are within quotes:
To open a database for editing, it is mandatory to have the .nam extension of the database file. Peditw.exe can open also the .rnr and .t9i files, but only for reading. Just like in PEDIT.exe, the .rnr and .t9i files can be generated using the .nam extension, vice versa does not work. The records can be edited using the F6 key.
The Edit menu has two options:
1.
Sort - a new sortation will be triggered, thus the database can be saved. This is useful when the .rnr and .t9i files are necessary but missing, because those files can be generated by pressing “Save”.
2.
Remove Duplicates - removes the entries with duplicated names and numbers. Peditw.exe allows to have duplicated names but different numbers, or duplicated numbers but different names. A warning message is displayed, when duplicated entries are found or when no duplicates exists.
The File > Import menu can be used to import data from other file format. This option will convert the selected data into PEDIT format to be able to generate the necessary .nam, .rnr and .t9i files for the DTB application.
Figure 18
The resulting file will be similar with the .txt file generated with PEDIT using the F9 key. A useful note for the user is that the quotes are not mandatory, but the column separator must be the semicolon (;).
2.
UTF8 data: uses UTF-8 characters which is a multibyte encoding scheme. This option is for import a .nam, .rnr or .t9i file which contains special characters, like umlauts, diacritics, accents and other special features relative to the basic 26 characters of the Latin alphabet. In this case, PEDIT will replace these characters with the most similar character from the basic Latin alphabet. This action is showed by a message window:
NOTE: Opening the UTF-8 file using the File > Open menu will result faulty data:
When opening a .nam file or when importing a .csv or an UTF-8 formatted .nam file, PEDIT will truncate the fields which are longer than 24 bytes. For example, when these files are edited manually or by other programs, then their size will not be integral multiple of 48 bytes or characters. The truncating action is displayed by a message window:
The search is available by the F7 key, and it is based on names. The search is performed only on the sorted database, therefore it is recommended to click on the Edit/Sort before using the search option.
The PEDIT tool can be closed using the File > Quit option or by pressing the Esc key on display mode.